BQ76952: Strange Subcommand Read error


I am very interested with the Libre Solar project, particularly the BMS. I am trying to run the BQ76952EVM with an STM32 dev board, using the same firmware for the Libre-Solar BMS, along with a few changes in the dts files.

I got a strange error when trying to init the IC. When trying to read the Manufacturing Status Register (0x0057), the buf_subcmd[] and buf_data[] is always mismatch, with the buf_data[] returning strange values (0xA8, 0x91), and the system fails to continue.

Have anyone seen this behavior before? Any help would be greatly appreciated.

I have solved the problem.

I didn’t notice that my dev board doesn’t have pull-up resistors on the I2C lines. How the system kinda works before without the resistors is beyond me.

Sorry for the trouble.

Great that you solved it.

In case of questions directly related to a particular repository (like the bms-firmware in this case) I recommend to raise an issue in the repository on GitHub. It will make it faster and easier to track and fix bugs.

Let me know if you experience other issues with the firmware.